Home > Update Alternatives Error > Update-alternatives Error No Alternatives For Gl_conf

Update-alternatives Error No Alternatives For Gl_conf

EDIT: Bumblebee experimental/unstable a week ago, but my changes should have make it more stable (read: does not break the system on upgrades). See Freedesktop Git Usage for directions on using git. 2. Updating Catalyst/fglrx[edit] DO NOT try to install a new version over an old one. Gino RoelitoRodasOctober 23rd, 2011, 11:07 PMhey man do you think you could send me the instructions about how to fix that bug?. Source

All I can really suggest (personally) is to add a startup item to run: gnome-shell --replace Should do it Phil-ganchev (phil-ganchev) said on 2011-11-20: #2 Yes, it is an option at Why does Wikipedia list an improper pronunciation of Esperanto? GinoMan2440October 28th, 2011, 04:30 AMThat's weird that lightdm is at the front of the list but it's not hurting anything.....Otherwise your path matches mine; what about alternatives? C.

Extract the zip file in your desktop and open a terminal cd ~/Desktop sudo sh amd-driver-installer-*.run --buildpkg Ubuntu/oneiric It will create 3 *.deb files in your desktop. To see the complete list: http://en.wikipedia.org/wiki/Unified_Video_Decoder#UVD_enabled_GPUs sudo apt-get install xvba-va-driver libva-glx1 libva-x11-1 vainfo vainfo vainfo should return something like the following (and no errors): libva: libva version 0.32.0 Xlib: extension "XFree86-DRI" You can enable xvba in Tools -> Preferences -> Input and Codecs. Here is a recipe which removes all old video drivers, and reinstalls nouveau: sudo nvidia-settings --uninstall sudo apt-get remove --purge nvidia* sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv sudo apt-get install nvidia-common

Hot Network Questions Why is the FBI making such a big deal out Hillary Clinton's private email server? A. D. drwxr-xr-x 6 root root 4096 2011-07-16 23:04 modules -rw-r--r-- 1 root root 31246 2010-11-29 16:34 protocol.txt drwxr-xr-x 2 root root 4096 2011-07-25 02:20 x11-extra-modules [email protected]:~$ ls -la /usr/lib/xorg/x11-extra-modules/ total 8 drwxr-xr-x

The following subsections will attempt to address possible (and tested) variations for their respective configurations. The fglrx driver includes kernel components which don't always get fully uninstalled when switching to -ati. UbuntuCommunityAsk!DeveloperDesignDiscourseHardwareInsightsJujuShopMore ›AppsHelpForumLaunchpadMAASCanonical current community chat Ask Ubuntu Ask Ubuntu Meta your communities Sign up or log in to customize your list. To remember the key-presses, remember this nonsensical phrase: "Raising Skinny Elephants Is Never Utterly Boring".

I was asking if you got an error for the previous command "dpkg -i fglrx*-bf-rc*.deb" if you did, then it's likely that fglrx did not install correctly, also if you use update-alternatives: error: unable to install /usr/lib32/libaticalcl.so.dpkg-tmp as /usr/lib32/libaticalcl.so: No such file or directory dpkg: error processing fglrx (--configure): subprocess installed post-installation script returned error exit status 2 dpkg: dependency problems prevent tsi commented Jul 28, 2011 thanks, spare time is the bigger issue ;) but I sure will. For example now I am able to use two monitors, that's incredible.!!

  1. If you have unusual hardware, such as a video card from a minor vendor, then a third possibility is that it needs a driver not available in the standard distribution (or
  2. it gives you command not found because the aticonfig tool is not Installed, you should get that fglrx is a broken package.
  3. These do not necessarily indicate that the installation has failed completely.
  4. I think it's the only thing keeping my machine with 3D support at this time so I'd rather keep it running until a stable Bumblebee release.
  5. Be advised that you may need to manually set the correct refresh rate for your second monitor through catalyst.

log out). Does anyone have another source or can re-upload the packages? i would really apreciate it. What I have to do to fix this problem?

If you're having issues with tearing, make sure that "Tear Free Video" is on. http://cloudindet.com/update-alternatives-error/update-alternatives-error-no-alternatives-for-xulrunner-1-9-javaplugin-so.html That is the default case if the alternatives system is misconfigured. Thanks for everything in advance. You can kill the hanging authatieventsd.sh processes from a console tty to allow the shutdown of the X server.

On the other hand, if you have older hardware, then if your hardware used to work with a non-vesa driver in the past, possibly support for your hardware has been dropped sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.orig Generate a new config: sudo amdconfig --initial -f Force use of the new xorg.conf. Not the answer you're looking for? have a peek here mkdir catalyst-14.6beta1.0jul11 && cd catalyst-14.6beta1.0jul11 wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux+x86' http://www2.ati.com/drivers/beta/linux-amd-catalyst-14.6-beta-v1.0-jul11.zip unzip linux-amd-catalyst-14.6-beta-v1.0-jul11.zip cd fglrx-14.20 Create and install .deb packages[edit] sudo ./amd-driver-installer-14.20-x86.x86_64.run --buildpkg Ubuntu/trusty sudo dpkg -i fglrx*.deb If building .deb packages fails, there

ATI/ATI Hybrids[edit] As of Catalyst 11-8, switching between two ATI cards (and maybe Intel/ATI muxless too?) is supposed to be doable, though it's not clear if that applies to all ATI/ATI So, after re-activate discrete graphics the keyboard returns OK. Strange device identification Why do the Sparkfun and Adafruit Eagle libraries use smaller footprints than the manufacturer's recommended land pattern?

Will seed when I am done downloading..

It appears that the "purge" didn't remove anything. What does this ice key do? Be advised that you may need to manually set the correct refresh rate for your second monitor through catalyst. If you receive this error, use the following command, which will force the installation of all of the 32 bit dependencies, and then the amdcccle package: sudo apt-get -f install Catalyst

Stop." 7.4 "Errors were encountered while processing: fglrx-amdcccle" (on 64-bit systems) 7.5 Problems Starting Xserver 7.6 Unsupported Hardware Watermark 7.7 Poor battery life (atieventsd not starting and/or not authenticating) 7.8 Hang command done on your old or new installation? In addition, -fglrx provides its own fglrx-specific version of libgl, which can cause breakage when running -ati. Check This Out So after a lot of forum...I try to follow Your suggestion to fic the Installer.run by I am not able to download the torrent file becouse the client remains in stalled

You can reinstate the file with: sudo mv /etc/X11/xorg.conf.disabled /etc/X11/xorg.conf Before tweaking ACPI settings, try ensuring /dev/null is chmodded to 0666. If they are listed but not found from /usr/bin, it is possible that the "update-alternatives" fglrx .deb installation does has been ignored. Sorry I couldn't be of any more assistance and thank you for all the help today. The stats box that shows up should display the following: "accelerated video rendering, accelerated video decoding" Revert to original drivers[edit] To revert to standard Ubuntu drivers sudo apt-get install ppa-purge sudo

dpkg: error processing fglrx-amdcccle (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of fglrx-dev: fglrx-dev depends on fglrx; however: Package fglrx is not configured yet. Updated Open Source Driver PPA's[edit] oibaf's ppa: https://launchpad.net/~oibaf/+archive/graphics-drivers Xorg-edgers: This bleeding-edge PPA offers video driver-related components straight from their code (git) repositories. For example, if dpkg complains: dpkg-divert: mismatch on divert-to when removing `diversion of /usr/lib/libGL.so.1.2 to /usr/share/fglrx/diversions/libGL.so.1.2 by xorg-driver-fglrx' found `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by xorg-driver-fglrx' then: sudo dpkg-divert --remove /usr/lib/libGL.so.1.2 Install the prerequisite packages: sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot libqtgui4 If you are using the x86_64 architecture (64 bit): sudo apt-get install lib32gcc1 If your /etc/modprobe.d/blacklist-local.conf

People don't run into it quite as much since -nv doesn't tap 3D functionalities as often, but it still happens. If you wish to fix it manually for Maverick and Lucid, follow the below instructions (which applies to Ubuntu systems below Oneiric) to fix the alternatives system: Remove the unsupported links If you installed the proprietary driver included with Ubuntu or you do not want to upgrade to a newer version, it may be possible to work around the issue by using if you acquire a later version package, great, but for the bulk of us, it's satisfying enough just to get the repository version to work.

To stop this behaviour you can run sudo apt-mark hold fglrx-dev fglrx-core fglrx fglrx-amdcccle If you later want to reenable this functionality you can run sudo apt-mark unhold fglrx-dev fglrx-core fglrx There might be an obsolete alternative that I've missed. @paulbnjl: could you try https://github.com/MrMEEE/bumblebee/issues/493#issuecomment-1662510; restart your X server (or machine). So now bumblebee work with the last hour update. There could be several reasons: 1.