Home > Urlopen Error > Urlopen Error Unknown Url Type Media

Urlopen Error Unknown Url Type Media

Comment 24 Dale Stimson 2006-11-03 11:15:48 EST and maybe add to the above (in comment 23), right before the createrepro command: rm -r repodata Comment 25 Răzvan Sandu 2006-11-07 02:00:00 EST Error: failed to retrieve Fedora/RPMS/emacs-21.4-17.i386.rpm from dvd error was [Errno 4] IOError: This is my problem. Does this also happen with the real DVD? (not that that would have any practical importance, because no one is going to connect a DVD drive, insert DVD, mount DVD, install I will let Jeremy comment officially. http://cloudindet.com/urlopen-error/urlopen-error-unknown-url-type-media-yum.html

Registered Linux User #490076 Reply With Quote 03-26-2009 #3 zengmao View Profile View Forum Posts Private Message View Articles Just Joined! Yet everyone that has commented on this bug so far has been using this since fc4. so i copied the entire directory content of /tmp/fc5_install to a DVD 6. I'm not sure what 'where' refers to, but I also get the useless 'media' urls from the lopoback mounted DVD images. > > I also expose the mounted DVD images from

But now I get the invalid media urls from the FC6 yum using the repodata from the FC5 DVDs. Learn More Red Hat Product Security Center Engage with our Red Hat Product Security team, access security updates, and ensure your environments are not exposed to any known security vulnerabilities. Log Out Select Your Language English español Deutsch italiano 한국어 français 日本語 português 中文 (中国) русский Customer Portal Products & Services Tools Security Community Infrastructure and Management Cloud Computing Storage JBoss Reply With Quote Quick Navigation Red Hat / Fedora Linux Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums Linux Forums Linux Forums Site News /

Join Date: Dec 2003 Last Activity: 12 June 2016, 11:03 PM EDT Location: /dev/ph Posts: 4,996 Thanks: 73 Thanked 475 Times in 437 Posts You are asking yum to install a Also, a diff between the two files would catch someoverlooked typo.The problem is deeper than this. Comment 74 Seth Vidal 2007-08-03 15:38:11 EDT closing Comment 75 Sergio Monteiro Basto 2007-08-04 01:45:17 EDT and is fix in 3.2.0 ? Bug212180 - (yummedia) yum problem: urlopen error unknown url type: media Summary: yum problem: urlopen error unknown url type: media Status: CLOSED CURRENTRELEASE Aliases: yummedia Product: Fedora Classification: Fedora Component: yum

This time I did the clean first and still got the error. Cleaning up Everything [[email protected] yum.repos.d]# yum install iptraf Loading "installonlyn" plugin Loading "security" plugin Loading "rhnplugin" plugin This system is not registered with RHN. Setting up Install Process Setting up repositories Reading repository metadata in from local files Parsing package install arguments Resolving Dependencies --> Populating transaction set with selected packages. Any ideas how to do this?

then copied all the rpms from the other disks and put those in the RPMS directory in the HDD. 3. media://1213888991.267240%231/CentOS/yum-metadata-parser-1.1.2-2.el5.i386.rpm: [Errno 4] IOError: Trying other mirror. I think my custom repository dvd.repo was not understood properly by yum. The workaround in comment #15 has worked well for me.

  1. Setting up Install Process Setting up repositories rhel-debuginfo 100% |=========================| 1.3 kB 00:00 Reading repository metadata in from local files Parsing package install arguments Resolving Dependencies --> Populating transaction set with
  2. For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration.
  3. Error: failed to retrieve xorg-x11-proto-devel-7.1-9.fc6.i386.rpm from Installer error was [Errno 4] IOError: [[email protected] yum.repos.d]# [[email protected] yum.repos.d]# Posted by Amit Chopra at 12:32 AM No comments: Post a Comment Newer Post
  4. How hard is that?
  5. it is related to creating the repodata Comment 64 Deepak Kumar Mishra 2007-03-26 07:47:46 EDT Hello People..
  6. Friends , I want to install package using yum from DVD in RHEL 5 .
  7. I agree that the createrepo workaround is the most straightforward one.
  8. After read this links: https://lists.dulug.duke.edu/pipermail/yum/2006-October/009240.html http://www.fedoraforum.org/forum/archive/index.php/t-133876.html It is hardcoded, but show how a problem could be resolved.
  9. I get the message with different rpms based on what I want to update.
  10. Here is the line in repo file for base: baseurl=file:///some_path/fedora/base/$releasever/$basearch/os/ It works fro FC4,5, but not FC6.

carltm View Public Profile View LQ Blog View Review Entries View HCL Entries Visit carltm's homepage! However, I noticed something odd recently that made me wonder if this is something that really could be fixed by yum. Password Home Search Forums Register Forum RulesMan PagesUnix Commands Linux Commands FAQ Members Today's Posts Red Hat Red Hat is the world's leading open source technology solutions provider with offerings including RHN support will be disabled.

Comment 14 Yanko Kaneti 2006-10-29 12:02:29 EST skvidal wrote: > There's no bug here. navigate here comps.xml contains the group/categories definitions and repomd.xml must refer to it references to "xml:base="media://1161131669.029329#1" in the original repomd.xml on DVD must be removed to fix the original problem. # mkdir -p Even if the claim that the install DVD works as intented is correct, this architecture doesn't make sense. Comment 46 Tamal Kanti Nath 2006-12-12 14:52:51 EST (In reply to comment #45) Ok, finally it worked for me.

However, we've refined our workaround here: After "exploding" the DVD to install-x86_64/ we then create at the same dir level, yum-x86_64/. Hence I just follow the below rules : 1) [[email protected] ~]# mount /dev/hdc /cdrom/ mount: block device /dev/hdc is write-protected, mounting read-only 2) Edit the yum rhel-debuginfo.repo file like following way yes i want to mention that, yum list all, yum update commands were running properly. Check This Out Results 1 to 1 of 1 Thread: Problem connecting to tracker - ('url error', 'unknown url type', 'udp', udp:tracker Thread Tools Show Printable Version Subscribe to this Thread… Display Linear Mode

You simply cannot use the repodata on the dvd/cds by default to install/upgrade using yum by itself. Code blocks~~~ Code surrounded in tildes is easier to read ~~~ Links/URLs[Red Hat Customer Portal](https://access.redhat.com) Learn more Close many ways to success The Hunger to find destination Friday, March 22, 2013 Perhaps some MIME lib that I pickedup from rpmforge, jpackage, or kbsingh....

This is a problem with both the i386 and x86_64 DVD images.

Need access to an account?If your company has an existing Red Hat account, your organization administrator can grant you access. Comment 11 Sam Varshavchik 2006-10-28 22:52:21 EDT *** Bug 212752 has been marked as a duplicate of this bug. *** Comment 12 Seth Vidal 2006-10-29 10:21:42 EST The media urls are it worked.. Is this really a bug in the DVD images, or was it caused by a change in yum?

Robert Moskowitz at Jul 3, 2008 at 4:26 pm ⇧ Kai Schaetzl wrote:Robert Moskowitz wrote on Thu, 3 Jul 2008 10:49:47 -0400:I should also mention that right now, I have a I copied it to a separate directory and export it using nfs to other systems. reply | permalink Toby Bluhm Just some guesses here . . . this contact form because about using dvd as base-repo for yum, nobody else you have complains, on ours techniques.

Comment 17 Sergio Monteiro Basto 2006-10-29 20:30:15 EST (In reply to comment #12) > The media urls are used by anaconda, not by yum. All Rights Reserved. We Acted. In fact I have both FC5 and FC6 in the same tree with the path /somthing_that_auto_mount_knows/base/.

Comment 8 josip 2006-10-28 03:47:02 EDT I see the same problem. FAQ Forum Quick Links Unanswered Posts New Posts View Forum Leaders FAQ Contact an Admin Forum Community Forum Council FC Agenda Forum Governance Forum Staff Ubuntu Forums Code of Conduct Forum yum upgrade gets it on chkconfig.So there is something that got on this system from one of the 3rd partyrepos that is causing the problem. Do you want to help us debug the posting issues ? < is the place to report it, thanks !

media error started coming. No change. (dated Jun 14,mine was dated Jun 24, the day I built my repo. Please visit this page to clear all LQ-related cookies. The time now is 08:10 AM.

Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.